VMware Client Integration – FireFox SSL Popup

I’ve been having this issue for a little while now, I hadn’t found any successful posts on how to allow the VMware Client integration plug-in to run on FireFox. This occur in my last lab environment and my current.  Unfortunately, without this integration tool, OVF deployments and various other functions are unavailable in the WebClient.
Error Msg: “The VMware Client Integration Plugin has updated its SSL Certificate in FireFox.”
Since Firefox ver. 52, plugins have been disabled by default and started to behave differently. We found this out the hardware when some of our customers were starting to open their SaaS Citrix environment with HTML5 instead of the thick client.
To fix this, I found a KB article that outlines the solution. (KBA 2112076)
As you can see, the integration tool is currently installed and in Firefox 56 the message is displaying after log on to the WebClient.
Screen Shot 2017-09-06 at 10.28.31 amScreen Shot 2017-09-06 at 10.27.43 am
Go ahead and uninstall the Integration Tool as you will need to reinstall it again.
Screen Shot 2017-09-06 at 10.31.15 am
 
Uninstall your current version of FireFox and download and install FireFox Extended Support Release
Screen Shot 2017-09-06 at 10.30.17 am
Once installed, reinstall the VMware Client Integration Plug-in and launch FireFox. The Plugin should then popup once you access your venter WebClient login page. -> Select “Remember my choice for vmware-csd links” and click “Open Link”
Screen Shot 2017-09-06 at 10.40.55 am
Head over to a host and attempt an OVF deployment.  A second pop will request for Access Control -> select “Allow” and untick “Always ask before allowing this site” (Unless security reasons)
Screen Shot 2017-09-06 at 10.42.08 am
You should now not see any error messages when you attempt an OVF deployment.
Screen Shot 2017-09-06 at 10.42.21 am

1 Trackback / Pingback

  1. Install and Configure NSX Manager – ReadySetVirtual.com

Leave a Reply

Your email address will not be published.


*